Forum ZitePLUS

La communauté des utilisateurs du CMS ZitePLUS

Vous n'êtes pas identifié(e).

#1 23/08/2012 17:32:16

Super_chemist
Membre
Inscription : 27/05/2011
Messages : 417

bug module Tmodule

Encore un autre bug

Plus précisément, il s'agit d'une série de notice PHP toutes identiques qui se déclenchent quand on essaye de trier le contenu d'un objet Tdocs.

Par exemple, sur une page qui affiche un zdiaporama, on a

[== Indéfini ==]
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP Notice:  Undefined index: extension in C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php on line 104
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP Stack trace:
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   1. {main}() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\index.php:0
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   2. zite->builder() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\index.php:6
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   3. zite->get_content() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:242
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   4. include() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:412
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   5. zite->page_module() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zdata\\accueil.txt:3
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   6. Tmodule::execute_module() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:632
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   7. Tzdiaporama->dojob() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tmodule.php:77
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   8. Tdocs->sort() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\module\\zdiaporama.php:263
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   9. uasort() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:131
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP  10. __lambda_func() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:131
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP  11. Tdocs->offsetGet() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:1

Et sur une page qui affiche un photoshow, on a ça

[== Indéfini ==]
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP Notice:  Undefined index: extension in C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php on line 104
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP Stack trace:
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   1. {main}() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\index.php:0
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   2. zite->builder() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\index.php:6
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   3. zite->get_content() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:242
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   4. include() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:412
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   5. zite->page_module() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zdata\\accueil.txt:15
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   6. Tmodule::execute_module() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\ziteplus.php:632
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   7. Tphotoshow->dojob() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tmodule.php:77
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   8. Tdocs->__construct() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\module\\photoshow.php:23
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP   9. Tdocs->_init() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:43
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP  10. Tdocs->_isFilter() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:77
[Thu Aug 23 17:19:20 2012] [error] [client ::1] PHP  11. Tdocs->offsetGet() C:\\Users\\Adrien\\Documents\\Aviron\\site internet\\pelles.chalonnaises\\zplus\\tdocs.php:57

On a le même genre de notice dans les popup tinymce de photoshow et de zdiaporama.

J'ai creusé un peu le code de Tmodule, mais ça fait appel si je ne m'abuse à des notions php que je ne maitrise pas.
Néanmoins, les "undefined index" ça se répare facilement en général wink


Je suis sous wamp avec une 092

Hors ligne

#2 24/08/2012 11:38:42

jpg
Administrateurs
Inscription : 19/11/2008
Messages : 2 074
Site Web

Re : bug module Tmodule

Super_chemist a écrit :

Encore un autre bug

Bug, quel vilain mot ... avertissement tout au plus roll

Super_chemist a écrit :

On a le même genre de notice dans les popup tinymce de photoshow et de zdiaporama.

J'ai creusé un peu le code de Tmodule, mais ça fait appel si je ne m'abuse à des notions php que je ne maitrise pas.
Néanmoins, les "undefined index" ça se répare facilement en général wink

Je regarderais dans la dernière version alpha en cours si cela est toujours d'actualité, car j'en ai déjà corrigé quelques uns wink

a+
Jean-Paul

Hors ligne

#3 24/08/2012 13:18:30

Super_chemist
Membre
Inscription : 27/05/2011
Messages : 417

Re : bug module Tmodule

Avertissement, certes...
Mais quand le site est mis en mode "développement", et qu'on se retrouve avec des notices de 2km de long en tête de page, ça s'apparente à un bug !

A+

Hors ligne

#4 25/01/2014 07:33:03

faris
Nouvel utilisateur
Inscription : 25/01/2014
Messages : 1

Re : bug module Tmodule

Je remercie pour ceux module qui est super, je dirais même plus, il est très bien expliqué et pas compliqué à utiliser, pour les bug il suffi de le savoir et on s'en accommode (petite idée peut être mettre des valeurs par défaut).


faris

Hors ligne

Pied de page des forums